Platforms

Nextflow Workbench can be installed on the following platforms:

  • Mac OS X 10.8.3+
  • Windows 8+ (only remote submissions supported at this time)
  • any Linux distribution supporting Java 8 (check here for a complete list)

At least, 4 GB of memory are required on the machine to properly run the software.

Install required software

Install Jetbrains MPS:
FOR MacOS USERS:

FOR WINDOWS USERS:

FOR LINUX USERS:

Install mbeddr Plugin Manager.
In the welcome screen, select Configure and then Plugins:

Then, click on “Browse Repositories…”, search for “mbeddr”, select the “mbeddr Plugin Manager” and click on the Install Plugin button.  Then restart the MPS application.
Install the MPS Nextflow Workbench plugin:

      • start the MPS application and open-up the plugin manager in MPS (menu MPS > Preferences… > Plugins (mbeddr)) and click on “Browse Repositories…”,

InstallNextflowWorkbenchPlugin

    • scroll the list of available plugins and install the plugin org.campagnelab.NextflowWorkbench

InstallNextflowWorkbenchPlugin

 

  • click OK when asked to install additional plugins on which NextflowWorkbench depends on
  • click OK button at the end of the screen
  • restart the application to activate the plugin
Enable automatic reference re-resolution in the editor. For that, you need to enable the corresponding flag on the Editor page in the Project settings (menu MPS>Preferences…>Editor >General) as shown: Enable broken references resolution

Verify the installation

    1. Start the MPS application and open-up the plugin manager in MPS (menu MPS > Preferences… > Plugins). Check that the org.campagnelab.NextflowWorkbench plugin is listed, is not red and the checkbox next to the plugin name is checked: Path variable